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1. Introduction 

This guide introduces how to use Eclipse to develop GD32 MCU. Applicable to GD32 RISC-

V series MCU. 
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2. Development environment 

 Development boards: GD32 MCU boards 

 Hardware Debugger: J-Link V10 or GD-Link 

 Operating system: WIN7/WIN10 64-bit OS 

 IDE: eclipse-embedcpp-2021-03-R-win32-x86_64 

 Cross toolchains: xpack-riscv-none-embed-gcc-10.1.0-1.1-win32-x64 

 Build Tools: gnu-mcu-eclipse-windows-build-tools-2.12-20190422-1053-win64 

 GDB server: OpenOCD / J-Link GDB Server CL V7.11a 
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3. Project development 

3.1. New project 

Open Eclipse, LAUCH eclipse-workspace. Under "File->New" option, uesr can choose to 

create a new C/C++ Project and select C Managed Build option. 

Figure 3-1. New RISC-V C project 
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Figure 3-2. Select C Managed Build 

 

Enter the “Project name” and configure the project type. For convenience, it is recommended 

to put the project in the FW directory. The compilation chain is selected as RISC-V Cross 

GCC. 
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Figure 3-3. Create new RISC-V project name and select project storage path 

 

If the Eclipse IDE has set the RISC-V Toolchains Path correctly, the path will be automatically 

selected here. If the Eclipse IDE has not set the RISC-V Toolchains Path, user can also select 

the absolute path to the RISC-V Toolchains here. 



AN067 
GD32 RISC-V MCU Eclipse development tutorial for Windows 

12 
 

Figure 3-4. Select RISC-V cross toolchain path 

 

Click "Finish" until the display interface is shown in Figure 3-5. Project perspective. At this 

point, the establishment of the Project is completed. 

Figure 3-5. Project perspective 

 

3.2. New project folder and add files 

3.2.1. Ceate folders and add files manually 

Right-click the project name and select “new->Folder”. 
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Figure 3-6. New project folder 

 

Create a virtual folder “Peripherals”. 

Figure 3-7. New virtual sub-folder 

 

Create the Application, Doc and Utilities folders in the same way. And create a Source sub-
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folder in the Peripherals folder. Create drivers, env_Eclipse and stubs sub-folders inside the 

RISCV folder. 

Figure 3-8. RISC-V project view 

 

Right-click “Application” and select the “Import” option to import the file. 
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Figure 3-9. Add files 

 

Import select “File System”. Select the path of the file to be imported, and tick the file to be 

imported. 

Figure 3-10. Select files to be imported 
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Figure 3-11. Import files to the Application folder 

 

In the same way, import the required files into the “RISCV”, “Doc”, “Peripherals” and “Utilities” 

folders. 
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Figure 3-12. Import files to the Peripherals folder 

 



AN067 
GD32 RISC-V MCU Eclipse development tutorial for Windows 

18 
 

Figure 3-13. Import files to the Peripheral-Source folder 
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Figure 3-14. Import files to the RISCV-env_Eclipse folder 
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Figure 3-15. Import files to the RISCV-drivers folder 
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Figure 3-16. Import files to the RISCV-stubs folder 
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Figure 3-17. Import files to the Doc folder 
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Figure 3-18. Import files to the Utilities folder 
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Figure 3-19. Final RISC-V project view 

 

3.2.2. Ceate folders and add files by “Refresh” 

In addition to the above-mentioned method of creating folders and importing corresponding 

files manually, user can also put the files that need to be imported together with its folders in 

the folder at the same level as the created .cproject file. In the Eclipse IDE, right-click the 

project name and select “Refresh” to import the folders and files into the project directly. 
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Figure 3-20. Project folder structure 

 

Figure 3-21. Refresh the project 
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Figure 3-22. Project structure in Eclipse IDE 

 

Note: The files and folders created in the "Refresh" method are all real, and once a file is 

deleted in the Eclipse IDE, the file will be deleted from the disk directly. 

3.3. Project configurations 

Right-click the project and select the “Properties” option to open it. 
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Figure 3-23. Project properties configurations 

 

3.3.1. Target Processor option configuration 

"C/C++ Build->Settings->Tool Settings->Target Processor" option configurations: 

According to the core of the target chip. In this guide, select RV32I. 



AN067 
GD32 RISC-V MCU Eclipse development tutorial for Windows 

28 
 

Figure 3-24. Target Processor configuration 

 

3.3.2. Optimization option configuration 

Configure the optimization level in the "C/C++ Build->Settings->Tool Settings->Optimization" 

option, with options -O0, -O1, -O2, -O3, -Os, -Ofast, -Og. 
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Figure 3-25. Optimization configuration 

 

3.3.3. GNU RISC-V Cross Assembler configuration 

Configure Cross C compilation options in the "C/C++ Build->Settings->Tool Settings->GNU 

RISC-V Cross Assembler" option. 

Add the Assembler header file path required by the project in the "includes->Include paths" 

option. Add In this guide: 

"${ProjDirPath}/../../Firmware/RISCV/drivers" 
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Figure 3-26. GNU RISC-V Cross Assembler -> Includes configuration 

 

3.3.4. GNU RISC-V Cross C Compiler configuration 

Configure Cross C compilation options in the "C/C++ Build->Settings->Tool Settings->GNU 

RISC-V Cross C Compiler" option. 

In this guide, add USE_STDPERIPH_DRIVER and GD32VF103V_EVAL pre-compiled 

macros in the ‘’Preprocessor->Defined symbols’ option. 
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Figure 3-27. GNU RISC-V Cross C Compiler -> Preprocessor configuration 

 

Add the header file paths required by the project in the "includes->Include paths" option. Add 

in this guide: 

"${ProjDirPath}/../../Firmware/RISCV/env_Eclipse" 

"${ProjDirPath}/../../Firmware/RISCV/drivers" 

"${ProjDirPath}/../../Firmware/GD32VF103_standard_peripheral/Include" 

"${ProjDirPath}/../../Template" 

"${ProjDirPath}/../../Utilities" 

"${ProjDirPath}/../../Firmware/RISCV/stubs" 

"${ProjDirPath}/../../Firmware/GD32VF103_standard_peripheral" 

Note: The header file path added in this guide is a relative path. User can also add the 

absolute path directly here. 
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Figure 3-28. GNU RISC-V Cross C Compiler -> Includes configuration 

 

3.3.5. GNU RISC-V Cross C Linker configuration 

Configure Cross C link options in "C/C++ Build->Settings->Tool Settings->GNU RISC-V 

Cross C Linker". 

Add in the "General ->Script files" option: 

"${ProjDirPath}/../../Firmware/RISCV/env_Eclipse/GD32VF103xB.lds" 

The linker script is responsible for telling the linker how to configure memory for the compiled 

executable file. The ld script used should conform to the FLASH and SRAM size of the target 

chip and the memory configuration required by the customer. 

Note: The ld file path added in this guide is a relative path. User can also add the absolute 

path directly here. 
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Figure 3-29. GNU RISC-V Cross C Linker -> General configuration 

 

In the “Miscellaneous” option, check “Use newlib-nano” and “Do not use syscalls”. (The code 

size can be optimized) 
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Figure 3-30. GNU RISC-V Cross C Linker -> Miscellaneous configuration 

 

3.3.6. Build Steps configuration-generate bin file 

In "C/C++ Build->Settings-> Build Steps", user can add commands to generate bin/hex files. 

Add in this guide:  

riscv-none-embed-objcopy -O binary "Project_RISCV.elf"  "Project_RISCV.bin"; riscv-

none-embed-objdump -D "Project_RISCV.elf" >  "Project_RISCV.dump" 
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Figure 3-31. Build Steps configuration 

 

3.4. Build project 

Select “Project->Build Project” to compile the current project. 

Note: “Build Project” is to compile the current project, and “Build All” is to compile all

 the projects in the current workspace. 

Figure 3-32. Build project 

 

Note: User need to save the current project before compiling each time, otherwise the 

compiling is the last project. After modification, in order to ensure the correctness, please 

clean the project first and then build. 
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After compiling, it can be seen that the corresponding elf, hex and bin files have been 

generated. 

Figure 3-33. Build RISC-V project completed 

 

3.5. Use J-Link to download and debug the project 

3.5.1. Debug configuration interface 

In the menu bar, click “Run->Debug Configurations” to enter the Debug configuration interface. 
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Figure 3-34. Enter Debug Configuratios interface 

 

Use J-Link GDBServerCL as the GDB Server, and use the GDB tool in the GCC tool chain 

as the GDB Client. 

Double-click GDB SEGGER J-Link Debugging to create a new set of J-Link configuration 

options. 
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3.5.2. Main tab 

Figure 3-35. GDB SEGGER J-Link Debugging-Main tab 

 

In the “Main” tab, select the current project, usually the elf file under the current project will be 

added automatically. If not, user can click “Browse” to add the elf file manually. 

Note: If user have compiled multiple models before, user need to select the corresponding 

executable elf file. For convenience, user can also create a new set of “Debug configuration” 

for each chip model. 

3.5.3. Debugger tab 

In the “Debugger” tab, fill in the device name of the target chip model, which is 

GD32VF103VBT6 in this guide. 

If the J-Link path has been configured correctly when setting up the Eclipse environment, it 

will be recognized automatically here. If user have not configured it correctly before, user can 

also select the absolute path of J-Link GDBServerCL in the “Executable path” column. 

Note: The chip model filled in “Device name” column must be supported by the J-Link driver 

which is selected here. If it is not supported, please upgrade the J-Link driver version. 
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Figure 3-36. GDB SEGGER J-Link Debugging-Debugger tab 

 

3.5.4. Startup tab 

In the “Startup” tab, configure type: 
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Figure 3-37. GDB SEGGER J-Link Debugging-Startup tab 

 

3.5.5. SVD Path tab 

In the “SVD Path” tab, select the SVD file required by the target chip. 

Figure 3-38. GDB SEGGER J-Link Debugging-SVD Path tab 
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3.6. Use GD-Link to download and debug the project 

3.6.1. Debug configuration interface 

In the menu bar, click “Run->Debug Configurations” to enter the Debug configuration interface. 

Figure 3-39. Enter Debug Configuratios interface 

 

Use OpenOCD as the GDB Server, and use the GDB tool in the GCC tool chain as the GDB 

Client. 

Double-click GDB OpenOCD Debugging to create a new set of OpenOCD configuration 

options. 
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3.6.2. Main tab 

Figure 3-40. GDB OpenOCD Debugging-Main tab 

 

In the “Main” tab, select the current project, usually the elf file under the current project will be 

added automatically. If not, user can click “Browse” to add the elf file manually. 

Note: If user have compiled multiple models before, user need to select the corresponding 

executable elf file. For convenience, user can also create a new set of “Debug configuration” 

for each chip model. 

3.6.3. Debugger tab 

If the OpenOCD path has been configured correctly when setting up the Eclipse environment, 

it will be recognized automatically here. If user have not configured it correctly before, user 

can also select the absolute path of OpenOCD in the “Executable path” column. 

In the “Config options” column, fill in the cfg file used. In this guide: 

-f ${eclipse_home}\eclipse_toolchain\OpenOCD\scripts\target\openocd_gdlink_gd32vf103.c

fg 

The cfg file of OpenOCD provides information such as debugger, debugging protocol, target 

chip identification and target chip programming algorithm selection. 
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In the “Commands” column, fill: 

set arch riscv:rv32 

Figure 3-41. GDB OpenOCD Debugging-Debugger tab 

 

3.6.4. SVD Path tab 

In the “SVD Path” tab, select the SVD file required by the target chip. 

Figure 3-42. GDB OpenOCD Debugging-SVD Path tab 
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3.7. Debug interface 

After the debug configurations is completed, click “Debug” to enter the Debug perspective. 

Figure 3-43. Enter Debug perspective -1 

 

Switch to Debug perspective. 

Figure 3-44. Enter Debug perspective -2 
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Figure 3-45. Debug perspective 

 

3.7.1. Toolbar introduction 

：resume 

：suspend 

：terminate 

：step into 

：step over 
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：step out 

：reset 

3.7.2. Registers view 

In the menu bar, select “Window->Show view->Registers” option, open it to view the value of 

general-purpose registers. 

Figure 3-46. Open Registers view 
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Figure 3-47. Registers view 

 

3.7.3. Peripherals view 

In the menu bar, select “Window->Show view->Peripherals” option, open to view the value of 

the peripheral registers. 
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Figure 3-48. Open Peripherals view 
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Figure 3-49. Peripherals view 

 

3.7.4. Memory view 

In the menu bar, select “Window->Show view->Memory” option, and click the "+" sign above 

the “Memory” window to open the corresponding memory address. 
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Figure 3-50. Open Memory view 

 

Figure 3-51. Memory view 

 

3.7.5. Expressions view 

In the menu bar, select "Window->Show View->Expressions" and click the "+" sign in the 

“Expressions” window to add and view the value of the corresponding variable. 
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Figure 3-52. Open Expressions view 

 

Figure 3-53. Expressions view 

 

Note: Ecplise can only view the value of the variable when the code is not running. It is 

temporarily unable to update the value of the variable in real time. 

3.7.6. Disassembly view 

Select the “Instruction Stepping Mode button” in the debug toolbar to open the disassembly 

window. 

Figure 3-54. Open Disassembly view 

 

In the disassembly window, breakpoints can be enabled, assembly instructions can be 

executed in single step, etc. 
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Figure 3-55. Disassembly view 

 

3.7.7. Exit the Debug perspective 

Click the "Stop debugging" button, and then click "C/C++" to enter the project perspective. 

Figure 3-56. Exit the Debug perspective 
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4. Import an existing project 

In addition to new projects, user can also import existing Eclipse projects directly. In the menu 

bar, click “File->Import”, select “General->Exisiting Projects into Workspace” to import the 

existing project, and click "Next". 

Figure 4-1. Import an existing project - 1 

 

Select the path of an existing project file, Eclipse will recognize all the projects under this path. 

Select the corresponding project, and click "Finish" to import the existing project. 
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Figure 4-2. Import an existing project - 2 
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5. Debug in RAM 

Step 1: Modify the link script and recompile the project (it is recommended to clean and then 

build) for example, as shown in Figure 5-1. Ld file memory map when debugging in RAM. 

Figure 5-1. Ld file memory map when debugging in RAM 

 

Step 2: In the “Debug Configurations->Startup” option, check “RAM application”. 

Figure 5-2. Debug configurations when debugging in RAM 

 

Step 3: Enter the Debug perspective when debugging in RAM, as shown in the figure below. 
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Figure 5-3. Debug perspective when debugging in RAM 
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6. Printing with printf 

6.1. Use steps 

Step 1: Add the following _write function definition to the file.  

ssize_t _write(int fd, const void* ptr, size_t len) { 

    const uint8_t * current = (const uint8_t *) ptr; 

    { 

        for (size_t jj = 0; jj < len; jj++) { 

            _put_char(current[jj]); 

 

            if (current[jj] == '\n') { 

                _put_char('\r'); 

            } 

        } 

        return len; 

    } 

 

    return _stub(EBADF); 

} 

Step 2: Redirect usart to the put_char function.  

int _put_char(int ch) 

{ 

    usart_data_transmit(USART0, (uint8_t) ch ); 

    while ( usart_flag_get(USART0, USART_FLAG_TBE)== RESET){ 

    } 

 

    return ch; 

} 

Step 3: Use the printf function to print normally. Note that “\n” needs to be added to printf 

function to flush the output stream. 

    printf("Running led test!\r\n"); 

6.2. Print floating point data configuration 

Print floating point data configuration:  

check the “-u _prinft_float” option in the project “Properties->C/C++ Build->Settings->Tool 

Settings->GNU RISC-V Cross C Linker->Miscellaneous” option. 
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Figure 6-1. Print floating point data configuration 

 

Note: 1. When using printf function, user need to add “\r\n” at the end of the printed content, 

for example, printf("Running led test!\r\n"). 2. Using printf function in GCC will greatly increase 

the size of the code. If it is an occasion that requires a high codesized size, printf function is 

not recommended. 
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7. Revision history 

Table 7-1. Revision history 

Revision No. Description Date 

1.0 Initial Release  

 

  

Jun.20, 2022
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