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1. Development environment 

 Development boards: GD32 MCU boards 

 Hardware Debugger: J-Link V9/V10 or GD-Link 

 Operating system: WIN7 64-bit OS 

 IDE: eclipse-embedcpp-2021-03-R-win32-x86_64 

 Cross toolchains: xpack-arm-none-eabi-gcc-10.2.1-1.1-win32-x64 

 Build Tools: gnu-mcu-eclipse-windows-build-tools-2.12-20190422-1053-win64 

 GDB server: OpenOCD / J-Link GDB Server CL V7.54b 
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2. Project development 

2.1. New project 

Open Eclipse, LAUCH eclipse-workspace. Under "File->New" option, uesr can choose to 

create a new C/C++ Project and select C Managed Build option. 

Figure 2-1. New ARM C project 
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Figure 2-2. Select C Managed Build 

 

Enter the “Project name” and configure the project type. For convenience, it is recommended 

to put the project in the FW directory. The compilation chain is selected as ARM Cross GCC. 
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Figure 2-3. Create new ARM project name and select project storage path 

 

If the Eclipse IDE has set the ARM Toolchains Path correctly, the path will be automatically 

selected here. If the Eclipse IDE has not set the ARM Toolchains Path, user can also select 

the absolute path to the ARM Toolchains here. 
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Figure 2-4. Select ARM cross toolchain path 

 

Click "Finish" until the display interface is shown in Figure 2-5. Project perspective. At this 

point, the establishment of the Project is completed. 

Figure 2-5. Project perspective 
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2.2. New project folder and add files 

2.2.1. Ceate folders and add files manually 

Right-click the project name and select “new->Folder”. 

Figure 2-6. New project folder 

 

Create a virtual folder “Peripherals”. 
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Figure 2-7. New virtual sub-folder 

 

Create the Application, CMSIS, Doc, Ld, Startup and Utilities folders in the same way. 
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Figure 2-8. ARM project view 

 

Right-click “Application” and select the “Import” option to import the file. 
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Figure 2-9. Add files 

 

Import select “File System”. Select the path of the file to be imported, and tick the file to be 

imported. 
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Figure 2-10. Select files to be imported 
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Figure 2-11. Import files to the Application folder 

 

In the same way, import the required files into the “CMSIS”, “Doc”, “Ld”, “Peripherals”, “Startup” 

and “Utilities” folders. 
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Figure 2-12. Import files to the CMSIS folder 

 

Figure 2-13. Import files to the Doc folder 
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Figure 2-14. Import files to the LD folder 
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Figure 2-15. Import files to the Peripherals folder 
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Figure 2-16. Import files to the Startup folder 

 



AN041 
   GD32 ARM MCU Eclipse development tutorial for Windows 

22 
  

Figure 2-17. Import files to the Utilities folder 

 



AN041 
   GD32 ARM MCU Eclipse development tutorial for Windows 

23 
  

Figure 2-18. Final ARM project view 

 

2.2.2. Ceate folders and add files by “Refresh” 

In addition to the above-mentioned method of creating folders and importing corresponding 

files manually, user can also put the files that need to be imported together with its folders in 

the folder at the same level as the created .cproject file. In the Eclipse IDE, right-click the 

project name and select “Refresh” to import the folders and files into the project directly. 
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Figure 2-19. Project folder structure 

 

Figure 2-20. Refresh the project 
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Figure 2-21. Project structure in Eclipse IDE 

 

Note: The files and folders created in the "Refresh" method are all real, and once a file is 

deleted in the Eclipse IDE, the file will be deleted from the disk directly. 

2.3. Project configurations 

Right-click the project and select the “Properties” option to open it. 
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Figure 2-22. Project properties configurations 

 

2.3.1. Target Processor option configuration 

"C/C++ Build->Settings->Tool Settings->Target Processor" option configurations: 

According to the core of the target chip, select cortex-m3, cortex-m4, cortex-m23 or cortex-

m33. In this guide, select cortex-m3. 
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Figure 2-23. Target Processor configuration 

 

2.3.2. Optimization option configuration 

Configure the optimization level in the "C/C++ Build->Settings->Tool Settings->Optimization" 

option, with options -O0, -O1, -O2, -O3, -Os, -Ofast, -Og. 
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Figure 2-24. Optimization configuration 

 

2.3.3. GNU Arm Cross C Compiler configuration 

Configure Cross C compilation options in the "C/C++ Build->Settings->Tool Settings->GNU 

Arm Cross C Compiler" option. 

In this guide, add USE_STDPERIPH_DRIVER and GD32F10X_CL pre-compiled macros in 

the ‘’Preprocessor->Defined symbols’ option. 
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Figure 2-25. GNU Arm Cross C Compiler -> Preprocessor configuration 

 

Add the header file paths required by the project in the "includes->Include paths" option. Add 

in this guide: 

"${ProjDirPath}/../../Firmware/CMSIS/GD/GD32F10x/Include" 

"${ProjDirPath}/../../Firmware/CMSIS" 

"${ProjDirPath}/../../Firmware/GD32F10x_standard_peripheral/Include" 

"${ProjDirPath}/../../Template" 

"${ProjDirPath}/../../Utilities" 

Note: The header file path added in this guide is a relative path. User can also add the 

absolute path directly here. 
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Figure 2-26. GNU Arm Cross C Compiler -> Includes configuration 

 

2.3.4. GNU Arm Cross C Linker configuration 

Configure Cross C link options in "C/C++ Build->Settings->Tool Settings->GNU Arm Cross C 

Linker". 

Add in the "General ->Script files" option: 

"${ProjDirPath}/../../Firmware/CMSIS/GD/GD32F10x/Source/GCC/gd32f10x_flash.ld" 

The linker script is responsible for telling the linker how to configure memory for the compiled 

executable file. The ld script used should conform to the FLASH and SRAM size of the target 

chip and the memory configuration required by the customer. 

Note: The ld file path added in this guide is a relative path. User can also add the absolute 

path directly here. 
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Figure 2-27. GNU Arm Cross C Linker -> General configuration 

 

In the “Miscellaneous” option, check “Use newlib-nano” and “Do not use syscalls”. (The code 

size can be optimized) 
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Figure 2-28. GNU Arm Cross C Linker -> Miscellaneous configuration 

 

2.3.5. Build Steps configuration-generate bin file 

In "C/C++ Build->Settings-> Build Steps", user can add commands to generate bin/hex files. 

Add in this guide:  

arm-none-eabi-objcopy -O binary "Project.elf" "Project.bin"; arm-none-eabi-objdump -D 

"Project.elf"> "Project.dump" 
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Figure 2-29. Build Steps configuration 

 

2.4. Build project 

Select “Project->Build Project” to compile the current project. 

Note: “Build Project” is to compile the current project, and “Build All” is to compile all

 the projects in the current workspace. 

Figure 2-30. Build project 

 

Note: User need to save the current project before compiling each time, otherwise the 

compiling is the last project. After modification, in order to ensure the correctness, please 
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clean the project first and then build. 

After compiling, it can be seen that the corresponding elf, hex and bin files have been 

generated. 

Figure 2-31. Build ARM project completed 

 

2.5. Use J-Link to download and debug the project 

2.5.1. Debug configuration interface 

In the menu bar, click “Run->Debug Configurations” to enter the Debug configuration interface. 
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Figure 2-32. Enter Debug Configuratios interface 

 

Use J-Link GDBServerCL as the GDB Server, and use the GDB tool in the GCC tool chain 

as the GDB Client. 

Double-click GDB SEGGER J-Link Debugging to create a new set of J-Link configuration 

options. 

2.5.2. Main tab 

Figure 2-33. GDB SEGGER J-Link Debugging-Main tab 
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In the “Main” tab, select the current project, usually the elf file under the current project will be 

added automatically. If not, user can click “Browse” to add the elf file manually. 

Note: If user have compiled multiple models before, user need to select the corresponding 

executable elf file. For convenience, user can also create a new set of “Debug configuration” 

for each chip model. 

2.5.3. Debugger tab 

In the “Debugger” tab, fill in the device name of the target chip model, which is GD32F107VC 

in this guide. 

If the J-Link path has been configured correctly when setting up the Eclipse environment, it 

will be recognized automatically here. If user have not configured it correctly before, user can 

also select the absolute path of J-Link GDBServerCL in the “Executable path” column. 

Note: The chip model filled in “Device name” column must be supported by the J-Link driver 

which is selected here. 

Figure 2-34. GDB SEGGER J-Link Debugging-Debugger tab 

 

2.5.4. SVD Path tab 

In the “SVD Path” tab, select the SVD file required by the target chip. 
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Figure 2-35. GDB SEGGER J-Link Debugging-SVD Path tab 

 

2.6. Use GD-Link to download and debug the project 

2.6.1. Debug configuration interface 

In the menu bar, click “Run->Debug Configurations” to enter the Debug configuration interface. 

Figure 2-36. Enter Debug Configuratios interface 

 

Use OpenOCD as the GDB Server, and use the GDB tool in the GCC tool chain as the GDB 
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Client. 

Double-click GDB OpenOCD Debugging to create a new set of OpenOCD configuration 

options. 

2.6.2. Main tab 

Figure 2-37. GDB OpenOCD Debugging-Main tab 

 

In the “Main” tab, select the current project, usually the elf file under the current project will be 

added automatically. If not, user can click “Browse” to add the elf file manually. 

Note: If user have compiled multiple models before, user need to select the corresponding 

executable elf file. For convenience, user can also create a new set of “Debug configuration” 

for each chip model. 

2.6.3. Debugger tab 

If the OpenOCD path has been configured correctly when setting up the Eclipse environment, 

it will be recognized automatically here. If user have not configured it correctly before, user 

can also select the absolute path of OpenOCD in the “Executable path” column. 

In the “Config options” column, fill in the cfg file used. In this guide: 

-f ${eclipse_home}\eclipse_toolchain\OpenOCD\scripts\target\openocd_gdlink_gd32f10x.cfg 

The cfg file of OpenOCD provides information such as debugger, debugging protocol, target 

chip identification and target chip programming algorithm selection. 
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Figure 2-38. GDB OpenOCD Debugging-Debugger tab 

 

2.6.4. SVD Path tab 

In the “SVD Path” tab, select the SVD file required by the target chip. 

Figure 2-39. GDB OpenOCD Debugging-SVD Path tab 

 

2.7. Debug interface 

After the debug configurations is completed, click “Debug” to enter the Debug perspective. 
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Figure 2-40. Enter Debug perspective -1 

 

Switch to Debug perspective. 

Figure 2-41. Enter Debug perspective -2 
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Figure 2-42. Debug perspective 

 

2.7.1. Toolbar introduction 

：resume 

：suspend 

：terminate 

：step into 

：step over 

：step out 
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：reset 

2.7.2. Registers view 

In the menu bar, select “Window->Show view->Registers” option, open it to view the value of 

general-purpose registers. 

Figure 2-43. Open Registers view 
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Figure 2-44. Registers view 

 

2.7.3. Peripherals view 

In the menu bar, select “Window->Show view->Peripherals” option, open to view the value of 

the peripheral registers. 
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Figure 2-45. Open Peripherals view 
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Figure 2-46. Peripherals view 

 

2.7.4. Memory view 

In the menu bar, select “Window->Show view->Memory” option, and click the "+" sign above 

the “Memory” window to open the corresponding memory address. 
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Figure 2-47. Open Memory view 

 

Figure 2-48. Memory view 

 

2.7.5. Expressions view 

In the menu bar, select "Window->Show View->Expressions" and click the "+" sign in the 

“Expressions” window to add and view the value of the corresponding variable. 



AN041 
   GD32 ARM MCU Eclipse development tutorial for Windows 

47 
  

Figure 2-49. Open Expressions view 

 

Figure 2-50. Expressions view 

 

Note: Ecplise can only view the value of the variable when the code is not running. It is 

temporarily unable to update the value of the variable in real time. 

2.7.6. Disassembly view 

Select the “Instruction Stepping Mode button” in the debug toolbar to open the disassembly 

window. 

Figure 2-51. Open Disassembly view 

 

In the disassembly window, breakpoints can be enabled, assembly instructions can be 

executed in single step, etc. 
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Figure 2-52. Disassembly view 

 

2.7.7. Exit the Debug perspective 

Click the "Stop debugging" button, and then click "C/C++" to enter the project perspective. 

Figure 2-53. Exit the Debug perspective 
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3. Import an existing project 

In addition to new projects, user can also import existing Eclipse projects directly. In the menu 

bar, click “File->Import”, select “General->Exisiting Projects into Workspace” to import the 

existing project, and click "Next". 

Figure 3-1. Import an existing project - 1 

 

Select the path of an existing project file, Eclipse will recognize all the projects under this path. 

Select the corresponding project, and click "Finish" to import the existing project. 
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Figure 3-2. Import an existing project - 2 
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4. Debug in RAM 

Step 1: Modify the linker script, for example, as shown in Figure 4-1. Ld file memory map 

when debugging in RAM. 

Figure 4-1. Ld file memory map when debugging in RAM 

 

Step 2: Relocate the interrupt vector table to SRAM. Recompile the project after completing 

steps 1 and 2. 

Figure 4-2. Relocate the interrupt vector table when debugging in RAM 

 

Step 3: In the “Debug Configurations->Startup” option, check “RAM application”. 
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Figure 4-3. Debug configurations when debugging in RAM 

 

Step 4: Enter the Debug perspective when debugging in RAM, as shown in the figure below. 
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Figure 4-4. Debug perspective when debugging in RAM 
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5. Printing with printf 

5.1. Use steps 

Step 1: Add the syscall.c file, and add the following _write function definition to the file.  

int _write(int file, char *ptr, int len) 

{ 

    int DataIdx; 

 

        for (DataIdx = 0; DataIdx < len; DataIdx++) 

        { 

           __io_putchar( *ptr++ ); 

        } 

    return len; 

} 

Step 2: Redirect usart to the __io_putchar function.  

int __io_putchar(int ch) 

{ 

    usart_data_transmit(EVAL_COM0, (uint8_t) ch ); 

while(RESET == usart_flag_get(EVAL_COM0, USART_FLAG_TBE)){ 

}; 

 

    return ch; 

} 

Step 3: Use the printf function to print normally.  

    printf("Running led test!\r\n"); 

5.2. Print floating point data configuration 

Print floating point data configuration:  

check the “-u _prinft_float” option in the project “Properties->C/C++ Build->Settings->Tool 

Settings->GNU Arm Cross C Linker->Miscellaneous” option. 
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Figure 5-1. Print floating point data configuration 

 

Note: 1. When using printf function, user need to add “\r\n” at the end of the printed content, 

for example, printf("Running led test!\r\n"). 2. Using printf function in GCC will greatly increase 

the size of the code. If it is an occasion that requires a high codesized size, printf function is 

not recommended. 
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6. Revision history 

Table 6-1. Revision history 

Revision No. Description Date 

1.0 Initial Release Nov.30, 2021 
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